ERROR WHILE ACTIVATING WEBLOGIC EDIT SESSION – ORACLE.NET.NS.NETEXCEPTION: UNKNOWN HOST SPECIFIED
I was configuring new datasource from admin console and got below error while activating datasource.
Error An error occurred during activation of changes, please see the log for details.
Error oracle.net.ns.NetException: Unknown host specified
Error Substituted for the exception oracle.net.ns.NetException which lacks a String contructor, original message – Unknown host specified
I have double checked datasource configuration and everything looked fine. My colleague, Vijay, suggested that there could be a problem with datasource other than current one. I went to jdbc config directory ($DOMAIN_HOME/config/jdbc directory and retrieved all hostnames using combination grep and awk commands. The suspicion came true, there was another hostname that was not getting resolved. We have untargeted datasoruces from all servers and activated changes and issue got resolved.
Comments
Post a Comment