Posts

Showing posts from September, 2020

ERROR WHILE ACTIVATING WEBLOGIC EDIT SESSION – ORACLE.NET.NS.NETEXCEPTION: UNKNOWN HOST SPECIFIED

I was configuring new datasource from admin console and got below error while activating datasource. Error An error occurred during activation of changes, please see the log for details. Error oracle.net.ns.NetException: Unknown host specified Error Substituted for the exception oracle.net.ns.NetException which lacks a String contructor, original message – Unknown host specified I have double checked datasource configuration and everything looked fine. My colleague, Vijay, suggested that there could be a problem with datasource other than current one. I went to jdbc config directory ($DOMAIN_HOME/config/jdbc directory and retrieved all hostnames using combination grep and awk commands. The suspicion came true, there was another hostname that was not getting resolved. We have untargeted datasoruces from all servers and activated changes and issue got resolved.

SOA DOMAIN CREATION FAILURE – CFGFWK-64038: THE APP-SVC NAME “ESSAPP” MUST HAVE TARGET

Image
We were building a domain with both SOA and ESS in same cluster. We got below error in domain configuration wizard during domain creation. CFGFWK-64254: Error occurred in “Artifacts Generation” phase execution Encountered Error: CFGFWK-64038: The app-svc name “ESSAPP” must have target. CFGFWK-64038: The app-svc name “ESSAPP” must have target. CFGFWK-64038: Provide a valid target. During ConfigMapping Reason for this error was that we selected  Oracle Enterprise Scheduler (ESS)  service in  Templates  screen of domain configuration wizard but it was not selected to deploy on any server. Fix to the problem is to select  ESS-MGD-SVRS  server group in  managed servers  screen. With this selection, ESS will be deployed on that particular managed server.