WEBLOGIC SERVER GOES TO FAILED_NOT_RESTARTABLE STATE
We have two node weblogic domain with SOA, OSB, ESS and WSM clusters. Server on one of the nodes was going to FAILED state and was not returning to RUNNING state even after multiple restarts. Logs have following messages:
Caused by: java.io.IOException: [DeploymentService:290066]Error occurred while downloading files from Administration Server for deployment request "51,325,278,609,827,905". Underlying error is: "[DeploymentService:290065]Deployment service servlet encountered an Exception while handling the deployment datatransfer message for request id "51,325,278,609,827,905" from server "wls_wsm1". Exception is: "files list is empty"." at weblogic.deploy.service.datatransferhandlers.HttpDataTransferHandler.getDataAsStream(HttpDataTransferHandler.java:92) at weblogic.deploy.service.datatransferhandlers.DataHandlerManager$RemoteDataTransferHandler.getDataAsStream(DataHandlerManager.java:175)weblogic.deploy.internal.targetserver.datamanagement.ConfigDataUpdate.doDownload(ConfigDataUpdate.java:153)<Nov 30, 2020 11:43:20 AM UTC> <Notice> <WebLogicServer> <BEA-000365> <Server state changed to FAILED.><Nov 30, 2020 11:43:20 AM UTC> <Error> <WebLogicServer> <BEA-000383> <A critical service failed. The server will shut itself down.><Nov 30, 2020 11:43:20 AM UTC> <Notice> <WebLogicServer> <BEA-000365> <Server state changed to FORCE_SHUTTING_DOWN.><Nov 30, 2020 11:43:21 AM UTC> <Info> <WebLogicServer> <BEA-000238> <Shutdown has completed.>The error message was similar to one of the earlier issues which was caused by misconfiguration of datasources. So, we looked for DB related errors in logs but didn’t find anything. Found below message in admin server logs after a second look:
Deployment service servlet received file download request for file "config/security/SerializedSystemIni.dat". The file may exist, but automatic download of this file is not allowed; it must be manually transferred
As you might already know, managed server copies configuration from admin server when it starts. It also checks its configuration version and timestamp for some files when it starts. Security file SerializedSystemIni.dat is not copied from admin server but checked for correctness by comparing timestamps etc (I am not sure what exact checks are done). So, we compared timestamps of DOMAIN_HOME/config/security/SerializedSystemIni.dat of both admin and managed server (Please check error message for exact file location, this file is located at multiple places and error can occur for any file). There was some timestamp difference between two files though file size and contents are same. We have copied file from admin server location to managed server location and this solved our problem. We are not yet aware reason for timestamp change.
Looks like there is a fix for transferring any type of file by applying patching and making changes to setEnv.sh (Doc id: 2154915.1). But we haven’t tried this option.
Edit: We also faced the same error recently when SerializedSystemIni.dat file got disappeared. Copying file from admin server resolved issue.
Comments
Post a Comment