ORACLE HTTP SERVER 12.2.1.4 FAILS TO START/SHUTS DOWN IN 2 MINUTES
Recently we built a collocated Oracle http Server (12.2.1.4.0) (OHS) server for POC purposes (This issue occurs in standalone ohs too). After configuring domain, I have started ohs server from em console. I verified that ohs processes were running by using ps -ef | grep ohs command. Satisfied with outcome I called it a day. Next day, I sshed into the machine, to my surprise there was no ohs process running. This time started ohs from command line using startComponent.sh. ohs server started, I was able to open ohs home page but not admin and em consoles. ohs processes were gone again after some time.
I tried to start it from em console and wlst script as well. But end result is same. Meanwhile, I observed a pattern that OHS processes are getting stopped after approximately 2 mins. As this a POC machine, we got single CPU VM. I thought due to limited cpu, startup process is taking time and eventually getting timed out. So I ran below command to find if there is any startup timeout with value of 2 mins/120 seconds.
cd $DOMAIN_HOME/config/fmwconfig/components/OHS
grep -R 120 *Found start-timeout parameter in $DOMAIN_HOME/config/fmwconfig/components/OHS/ohs1/ohs.plugins.nodemanager.properties. Increased it 600 seconds (10 mins) and started ohs again. It stopped again after 10 mins. So, safely ruled out that it was not hardware capacity issue.
Luckily, quick search in Oracle metalink gave me a pointer about the issue. As per Doc ID 2606314.1, issue is caused due to default wallet configured for localhost. I have followed solution 1 mentioned in the doc and problem resolved. Solution is to change Listen and Virtual hosts to 127.0.0.1 in admin.conf file.
Note: If you are using collocated ohs, don’t forget to stop admin server before making config changes.
Comments
Post a Comment