ORACLE CLOUD INFRASTRUCTURE (OCI) – NO SUPPORTED AUTHENTICATION METHODS AVAILABLE (SERVER SENT: PUBLICKEY,GSSAPI-KEYEX,GSSAPI-WITH-MIC)
I was experimenting with Oracle Cloud Infrastructure (OCI) with free tier account. I have created an VM and tried to login using public ip of the VM using private ssh key. But recevied below error:
No supported authentication methods available (server sent: publickey,gssapi-keyex,gssapi-with-mic)After reading OCI documentation, found that OCI by default has some policies that disable access to VMs. Issue resolved after creating new policy with following entries (Menu -> Identity -> Policies -> Create Policy -> Fill all fields -> Click on Customize (Advanced):
Allow group Administrators to inspect users in tenancy
Allow group Administrators to inspect users in tenancy
Allow group Administrators to inspect groups in tenancy
Allow group Administrators to inspect groups in tenancy
Allow group Administrators to use users in tenancy where target.group.name != 'Administrators'
Allow group Administrators to use users in tenancy where target.group.name != 'Administrators'
Allow group Administrators to use groups in tenancy where target.group.name != 'Administrators'This error also sometimes occurs when we login from Putty (Didn’t get it from MobaXterm). Putty throws this warning “Unable to use key file “Keys\private.ppk” (OpenSSH SSH-2 private key (old PEM format))“. If we ignore this warning and go ahead with login, we get same error as mentioned above. Solution to this problem is to convert key format. Steps are:
1. Open PuttyGen application.
2. Click on Conversions -> Import Key -> Save Private Key.
3. Use newly generated private key for logging in.
Comments
Post a Comment