JAVA APPLICATION IS NOT VISIBLE IN WEBLOGIC DEPLOYMENTS CONTROL TAB

 We recently deployed a Java application. After deployment it went into prepared state and we had to start it. But app was visible under deployments ->Configuration tab but not under control tab. As a quick fix, we thought of restarting managed server. But it didn’t work.

So, we tried to start the application using wlst and got “Operation cannot be performed until the server is restarted.” as shown below:

$FMW_HOME/oracle_common/common/bin/wlst.sh

Initializing WebLogic Scripting Tool (WLST) ...

wls:/offline> connect('weblogic','welcome1','t3://MyHost:7001')
Successfully connected to Admin Server "AdminServer" that belongs to domain "My_Domain".

wls:/My_Domain/serverConfig/> startApplication('MyApp')
Starting application MyApp.
<Nov 17, 2020 7:18:33 AM GMT> <Info> <J2EE Deployment SPI> <BEA-260121> <Initiating start operation for application, MyApp [archive: null], to PWBMS .>
weblogic.management.ManagementException: [Deployer:149188]No application named "MyApp" exists for operation start. Operation cannot be performed until the server is restarted.
Failed to start the application with status failed
Current Status of your Deployment:
Deployment command type: start
Deployment State : failed
Deployment Message : weblogic.management.ManagementException: [Deployer:149188]No application named "MyApp" exists for operation start. Operation cannot be performed until the server is restarted.
Traceback (innermost last):
  File "<console>", line 1, in ?
  File "<iostream>", line 312, in startApplication
        at weblogic.management.scripting.core.ExceptionCoreHandler.handleException(ExceptionCoreHandler.java:63)
        at weblogic.management.scripting.WLSTUtils.throwWLSTException(WLSTUtils.java:338)
        at weblogic.management.scripting.JSR88DeployHandler.startApplication(JSR88DeployHandler.java:945)
        at weblogic.management.scripting.WLScriptContext.startApplication(WLScriptContext.java:1048)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
        at java.lang.reflect.Method.invoke(Method.java:498)

weblogic.management.scripting.ScriptException: weblogic.management.scripting.ScriptException: Error occurred while performing startApplication : Failed to start the application with status failed
wls:/My_Domain/serverConfig/> WLST lost connection to the WebLogic Server that you were connected to.
This may happen if the server was shut down or partitioned.
You will have to re-connect to the server once the server is available.
Disconnected from weblogic server: AdminServer

I went to Change Center -> View Changes and restarts -> Restart Checklist. Adminserver was listed in server restart checklist. So, we restarted Admin server and application appeared in control tab.

Comments

Popular posts from this blog

HOW WE REDUCED SOA OSB PROVISIONING FROM 4 DAYS TO 4 HOURS

NOT ABLE TO START RABBITMQ CLUSTER: CANNOT DECLARE A QUEUE ‘~S’ ON NODE ‘~S’: ~255P

SOA SUITE 12.2.1.4 INSTALLATION: GOT EXCEPTION WHEN AUTO CONFIGURING THE SCHEMA COMPONENT(S) WITH DATA OBTAINED FROM SHADOW TABLE