Lonely Admin Server Refused to Start
We had an interesting problem over weekend and thought of sharing with all. One of my colleagues called me up and told that admin server in OSB cluster was not starting up and process was hanging. Here are the steps we followed to troubleshoot the issue.
1) He told that server had been up more than a week and he added JMX port before restarting the server.
He was very confident that it was not causing issue. But I insisted to rollback this recent change and start again. Situation was not improved, server startup was hanging again. So, we rule out that this change was not causing issue.
2) We ran top command and checked if there was any pressure on resources. cpu, memory and load average were very low.
3) Checked log files for potential errors. Nothing useful information was found in logs too.
4) The symptoms were similar to recent issue I have worked on. So, we ran lsof command to find if server was waiting for any network connection (lsof -a -i4 -i6 -itcp -p <pid>).
Comments
Post a Comment