Lonely Admin Server Refused to Start

We had an interesting problem over weekend and thought of sharing with all. One of my colleagues called me up and told that admin server in OSB cluster was not starting up and process was hanging. Here are the steps we followed to troubleshoot the issue.

1) He told that server had been up more than a week and he added JMX port before restarting the server.

He was very confident that it was not causing issue. But I insisted to rollback this recent change and start again. Situation was not improved, server startup was hanging again. So, we rule out that this change was not causing issue.

2) We ran top command and checked if there was any pressure on resources. cpu, memory and load average were very low.

3) Checked log files for potential errors. Nothing useful information was found in logs too.

4) The symptoms were similar to recent issue I have worked on. So, we ran lsof command to find if server was waiting for any network connection (lsof -a -i4 -i6 -itcp -p <pid>). 

lsof showed some TCP connections with syn_sent status. TCP syn_sent status means SYN packet is sent and waiting for acknowledgment from the other side of the connection. Those connections were for managed servers in the cluster. So, we ran few more network tests like telnet to confirm about network connectivity issue. We were not able to connect from admin server to managed server.
Raised incident with network team and they told that there was a network change last night and they missed to add admin server to some network rule. We were able to start admin server after network rule was added. 
I feel, admin server should have been designed to start even though managed servers are not accessible. At least, it would have failed after trying 10 or 20 mins and written something into logs to aid quicker debugging.
On a lighter note, weblogic servers too need social connections like humans to work properly ?.

Comments

Popular posts from this blog

HOW WE REDUCED SOA OSB PROVISIONING FROM 4 DAYS TO 4 HOURS

NOT ABLE TO START RABBITMQ CLUSTER: CANNOT DECLARE A QUEUE ‘~S’ ON NODE ‘~S’: ~255P

SOA SUITE 12.2.1.4 INSTALLATION: GOT EXCEPTION WHEN AUTO CONFIGURING THE SCHEMA COMPONENT(S) WITH DATA OBTAINED FROM SHADOW TABLE