Server failed to start up but Node Manager was not aware of the reason
Server startup failed with below error while trying to start with WLST script:
This Exception occurred at Mon Mar 05 16:28:14 GMT 2018.weblogic.nodemanager.NMException: Received error message from Node Manager Server: [Server start command for WebLogic server ‘osb_server2’ failed due to: [Server failed to start up but Node Manager was not aware of the reason]. Please check Node Manager log and/or server ‘osb_server2’ log for detailed information.]. Please check Node Manager log for details.Problem invoking WLST – Traceback (innermost last):File “/home/aosbpre/scripts/startMS.py”, line 29, in ?File “<iostream>”, line 188, in nmStartFile “<iostream>”, line 553, in raiseWLSTExceptionWLSTException: Error occurred while performing nmStart : Error Starting server osb_server2 : Received error message from Node Manager Server: [Server start command for WebLogic server ‘osb_server2’ failed due to: [Server failed to start up but Node Manager was not aware of the reason]. Please check Node Manager log and/or server ‘osb_server2’ log for detailed information.]. Please check Node Manager log for details.Use dumpStack() to view the full stacktrace :
Resolution: Provided wrong hostname in wlst. So it connected to wrong node manager and osb_server2 was not running on that machine (Password is same for both nodes so didn’t get authentication error). Able to start server after changing hostname in the script.
Comments
Post a Comment