Not Able to Start Weblogic/MFT Server After Out of Memory Error
There is a known bug in Oracle Managed File Transfer (MFT) which causes leaking of connections. This used to cause OOM error once in a month. We have an alert – which sends mail if heap usage is greater than 95% and 3 consecutive garbage collections not able to free much heap space. As we have two node cluster, we restart the server which reached heap utilization of more than 95%. On that particular day, the person on shift missed the alert. He checked alter after sometime and server health became ‘Not Reachable’.
Checked if there was any zombie process running (ps aux | grep Z). Yes, there was a zombie process. It was server process. Looks like server shutdown didn’t cleanly shutdown the server. Weblogic will not allow to run another process to run unless this zombie process is killed
Comments
Post a Comment