Not Able to Start Weblogic/MFT Server After Out of Memory Error

There is a known bug in Oracle Managed File Transfer (MFT) which causes leaking of connections. This used to cause OOM error once in a month. We have an alert – which sends mail if heap usage is greater than 95% and 3 consecutive garbage collections not able to free much heap space. As we have two node cluster, we restart the server which reached heap utilization of more than 95%. On that particular day, the person on shift missed the alert. He checked alter after sometime and server health became ‘Not Reachable’.

He tried to restart from console but he was not able to stop it and server status was showing as ‘RUNNING’. He tried to restart from command line even it didn’t work. He gave me a call. I faced similar issue when I was working for a different customer. So I was quickly able to identify issue.  

Checked if there was any zombie process running (ps aux | grep Z). Yes, there was a zombie process. It was server process. Looks like server shutdown didn’t cleanly shutdown the server. Weblogic will not allow to run another process to run unless this zombie process is killed

Parent id of this zombie is 1 which is init. So, we have rebooted VM and able start the MFT server post VM reboot.

Comments

Popular posts from this blog

SOA SUITE 12.2.1.4 INSTALLATION: GOT EXCEPTION WHEN AUTO CONFIGURING THE SCHEMA COMPONENT(S) WITH DATA OBTAINED FROM SHADOW TABLE

HOW WE REDUCED SOA OSB PROVISIONING FROM 4 DAYS TO 4 HOURS

RABBITMQ CONNECTION ERROR: JAVAX.NET.SSL.SSLHANDSHAKEEXCEPTION: INVALID ECDH SERVERKEYEXCHANGE SIGNATURE