Mystery Solved - Why My OSB Server is Taking lot of Time to Comeup
Once one of my teammates called me up and told me that OSB server in test environment is not coming up. He told me that he tried restarting servers multiple times and there is no luck.
The previous day, I have setup a monitoring script in that environment. So initially, I was misguided by a statistics related error and initial efforts gone in that direction.
From my experience, initial startup errors could be due to network or db. So I have ran lsof command and found that there was a connection to remote jms and socket status is SYN_SENT (lsof -p | grep TCP | grep -v ESTABLISHED). This gave me enough clue and revisited logs and found below error.
<11-Apr-2019 07:10:29 o’clock BST> << eis/jms/XXX_RemoteTopic > ResourceAllocationException generated by resource adapter on call to ManagedConnectionFactory.createManagedConnection(): “BINDING.JCA-12141
ERRJMS_CONN_FAC_NOT_FOUND.
ERRJMS_CONN_FAC_NOT_FOUND.
Unable to instantiate connection factory. JMS adapter was unable to look up the connection factory weblogic.jms.XAConnectionFactory neither through JNDI nor instantiate it as a Java class.
This log message has confirmed that server is waiting to connect to remote host and retrying. Instead of making changes, we have waited for 40 minutes and server came up. Post that we have removed that remote jms configuration and server startup time reduced from 40 mins to 5 mins. By default weblogic jms tries 10 times hence the delay in startup time.
Later found that this problem existed few weeks ago but the other engineer used to wait for 45 mins. But on this day, we got a new team member and she got panicked after seeing server in STARTING state for a long period and kept on restarting server. Fixing root cause saved 40 mins of our time every time we restart server.
Comments
Post a Comment