MFT_WS_EVENT_SERVICE_EVENT_ALREADY_ACTIVE_ON_SOURCE Error in Oracle Managed File Transfer

MFT supports 3 ways of transferring files:
1) Polling
2) Schedule
3) Events
Each one has different use case. Event based is used if you want to transfer a file based on an event. e.g., Trigger file transfer after completion of an extract process.
Following error occurred in our production environment when an external application invoked MFT:
Caused By: javax.xml.ws.soap.SOAPFaultException: MFT Event processing failed with exception code: MFT_WS_EVENT_SERVICE_EVENT_ALREADY_ACTIVE_ON_SOURCE           at com.sun.xml.ws.fault.SOAP11Fault.getProtocolException(SOAP11Fault.java:197)                at 
MFT doesn’t allow parallel processing of events. So, calling application has to call MFT sequentially. In our case, there was no pending file transfer and previous file was successfully transferred. It seems a bug in MFT and it was not able to mark the transfer as complete.
There are two ways to mark the previous transfer as complete: 1) Update Database 2) WLST.
First method is not suggested solution. But steps are provided here for completeness. 
1) Using Database Update:
Step 1: Find the event id which is stuck in ‘IN_PROGRESS’.
select ID from mft_trigger_event where source_name='Name of the Source' and status = 'IN_PROGRESS';
2) Update event status to ‘DONE’
SQL> update mft_trigger_event SET STATUS='DONE' where ID='ID obtained in first stpe';
SQL> commit;
2) Using WLST:
updateTriggerEventStatus('<status>', '<sourceName>', '<eventSessionId>') 
Please refer to Oracle Doc ID 2168702.1 for more information.

Comments

Popular posts from this blog

HOW WE REDUCED SOA OSB PROVISIONING FROM 4 DAYS TO 4 HOURS

NOT ABLE TO START RABBITMQ CLUSTER: CANNOT DECLARE A QUEUE ‘~S’ ON NODE ‘~S’: ~255P

SOA SUITE 12.2.1.4 INSTALLATION: GOT EXCEPTION WHEN AUTO CONFIGURING THE SCHEMA COMPONENT(S) WITH DATA OBTAINED FROM SHADOW TABLE