502 Bad Gateway Error when Oracle WebCenter Lift and Shifted to Azure Cloud

Our client had decided to move most of the OnPrem applications to Azure Cloud to save costs. As part of this we were asked to migrate multiple Oracle Middleware applications to Azure Cloud. One of them was Oracle WebCenter. Though the issue reported here is applicable to any Oracle Middleware products.

Our setup has LB, two Oracle http servers and 2 WebCenter servers. We have cloned DB, OHS and WebCenter applications to Azure cloud. After few changes, we were able to bring up admin console and managed servers but we were not able to access console using LB, we were getting 502 Bad Gateway error from Azure Application Gateway. But same urls were perfectly working fine when we either hit ohs or admin server ips directly.

The issue was dragged for couple of days and we were worried a lot as we had very tight timelines. We have analyzed server logs but didn’t find anything suspicious except that few errors in OHS access logs. But these http requests were not sent by us as part of our testing and later found that these were sent by Azure Application Gateway (LB) to check health of backend servers. I have compared these logs with existing On-Prem access logs. There was the issue !!!

Azure was using different resource path for checking health of backend WebCenter servers than the On-Prem servers. This url is not available on WebCenter and so these health probes were failing. So, LB is marking the servers as unhealthy and throwing 502 bad gateway to client. Our network team changed health probe url and we were able to access applications through LB.

Comments

Popular posts from this blog

HOW WE REDUCED SOA OSB PROVISIONING FROM 4 DAYS TO 4 HOURS

NOT ABLE TO START RABBITMQ CLUSTER: CANNOT DECLARE A QUEUE ‘~S’ ON NODE ‘~S’: ~255P

SOA SUITE 12.2.1.4 INSTALLATION: GOT EXCEPTION WHEN AUTO CONFIGURING THE SCHEMA COMPONENT(S) WITH DATA OBTAINED FROM SHADOW TABLE