Cryptic SOA Composite Deployment Error
Today I have developed a SOA composite that exposes REST service. It takes the input payload and does little transformation and inserts data into EBS database. When tried to deploy composite from em console, it was taking lot of time and eventually timing out after 20 mins.
Following is the error message from console:
Redeploying on /Domain_soa_domain/soa_domain/soa_cluster …Redeploying on “/Domain_soa_domain/soa_domain/soa_cluster” failed!There was an error deploying/undeploying composite on soa_server1: Timed out waiting for operation to complete..
Following error message was also seen in server diagnostic logs:
[2020-05-14T11:59:38.623+02:00] [soa_server1] [ERROR] [SOA-21537] [oracle.integration.platform.blocks.deploy.servlet] [tid: [STUCK].ExecuteThread: ’12’ for queue: ‘weblogic.kernel.Default (self-tuning)’] [userId: abcd] [ecid: fc57ea65-187d-47db-9331-e8a09e3ded00-0005e3eb,0:1:1] [APP: soa-infra] [partition-name: DOMAIN] [tenant-name: GLOBAL] [DSID: 0000N8IZRaxFw0NFEJr2CC1UYh6E0004ar] Sending back error message: There was an error deploying the composite on soa_server1: Timed out waiting for operation to complete…
Initially, I was looking around this error message but didn’t find any useful information. Searched Oracle metalink. But didn’t find any document that is relevant to my issue. One of my colleagues told me that he got similar error if there is any issue with adapter configuration.
When I looked up in the log files. Found below error 20 mins earlier to timeout.
[2020-05-14T11:39:48.748+02:00] [soa_server1] [WARNING] [] [oracle.soa.adapter] [tid: DistributedCache:soa_coherence_gar:SOAFabricCache:EventDispatcher] [userId: <anonymous>] [ecid: 3401d064-8135-4452-a226-78c599684db7-0594b55e,0] [APP: soa-infra] [partition-name: DOMAIN] [tenant-name: GLOBAL] JCA Deployment Validation failed for Adapters/Composite_db.jca:[[Problem 1: [ <connection-factory> <xml-fragment UIConnectionName=”EBSDEV” location=”eis/DB/EBSDEV”/>]:The JCA Binding Component is unable to locate the Resource Adapter specified in the <connection-factory/> element: DOMAIN location=’eis/DB/EBSDEV’The reason for this is most likely that either1) the Resource Adapters RAR file has not been deployed successfully to the WebLogic J2EE Application server or2) the JNDI <jndi-name> setting in the WebLogic JCA deployment descriptor has not been set to eis/DB/EBSDEV. In the last case you might have to add a new ‘connector-factory’ entry (connection) to the deployment descriptor.Please correct this and then restart the WebLogic Application Server
So, the issue was caused by missing adapter connection factory eis/DB/EBSDEV. After creating DB adapter connection factory from admin console. I was able to deploy composite.
Looks like, deployment module is not properly handling validation errors and waiting till timeout occurs (20 mins).
Comments
Post a Comment